What’s Vulnerable › Vulnerabilities
CVE-2022-3134: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-06 · updated 2026-09-24
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0389.
Affected products
- Debian Linux: 10.0, 11.0
- Neovim: from 0.5.0 before 0.9.0 — fixed in 0.9.0
- vim/vim: before 9.0.0389 — fixed in 9.0.0389
How to fix
Upgrade to a fixed version: Neovim 0.9.0; vim/vim 9.0.0389. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/ccfde4d028e891a41e3548323c3d47b06fb0b83e
- https://huntr.dev/bounties/6ec79e49-c7ab-4cd6-a517-e7934c2eb9dc
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/ccfde4d028e891a41e3548323c3d47b06fb0b83e
- https://huntr.dev/bounties/6ec79e49-c7ab-4cd6-a517-e7934c2eb9dc
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-3134 or the next vulnerability affects your stack