What’s Vulnerable › Vulnerabilities
CVE-2022-3136: Social Rocket < 1.3.3 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social Rocket WordPress plugin before 1.3.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- socialrocket Social Rocket – Social Sharing Plugin: before 1.3.3 — fixed in 1.3.3
How to fix
Upgrade to a fixed version: socialrocket Social Rocket – Social Sharing Plugin 1.3.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/913d7e78-23f6-4b0d-aca3-17051a2dc649
- https://wpscan.com/vulnerability/913d7e78-23f6-4b0d-aca3-17051a2dc649
Get alerted when CVE-2022-3136 or the next vulnerability affects your stack