What’s Vulnerable › Vulnerabilities
CVE-2022-31394
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
- Weakness: CWE-770
Description
Hyperium Hyper before 0.14.19 does not allow for customization of the max_header_list_size method in the H2 third-party software, allowing attackers to perform HTTP2 attacks.
Affected products
- hyperium hyper: before 0.14.19 — fixed in 0.14.19
How to fix
Upgrade to a fixed version: hyperium hyper 0.14.19. Check the vendor advisory for mitigations.
References
- https://github.com/hyperium/hyper/compare/v0.14.18...v0.14.19
- https://github.com/hyperium/hyper/issues/2826
- https://github.com/hyperium/hyper/pull/2828
- https://github.com/hyperium/hyper/compare/v0.14.18...v0.14.19
- https://github.com/hyperium/hyper/issues/2826
- https://github.com/hyperium/hyper/pull/2828
Get alerted when CVE-2022-31394 or the next vulnerability affects your stack