What’s Vulnerable › Vulnerabilities
CVE-2022-3142: NEX-Forms < 7.9.7 - Authenticated SQLi
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-19 · updated 2026-06-17
- Weakness: CWE-89
Description
The NEX-Forms WordPress plugin before 7.9.7 does not properly sanitise and escape user input before using it in SQL statements, leading to SQL injections. The attack can be executed by anyone who is permitted to view the forms statistics chart, by default administrators, however can be configured otherwise via the plugin settings.
Affected products
- webaways NEX-Forms – Ultimate Forms Plugin for WordPress: before 7.9.7 — fixed in 7.9.7
How to fix
Upgrade to a fixed version: webaways NEX-Forms – Ultimate Forms Plugin for WordPress 7.9.7. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/171477/WordPress-NEX-Forms-SQL-Injection.html
- https://medium.com/%40elias.hohl/authenticated-sql-injection-vulnerability-in-nex-forms-wordpress-plugin-35b8558dd0f5
- https://wpscan.com/vulnerability/8acc0fc6-efe6-4662-b9ac-6342a7823328
- http://packetstormsecurity.com/files/171477/WordPress-NEX-Forms-SQL-Injection.html
- https://medium.com/%40elias.hohl/authenticated-sql-injection-vulnerability-in-nex-forms-wordpress-plugin-35b8558dd0f5
- https://wpscan.com/vulnerability/8acc0fc6-efe6-4662-b9ac-6342a7823328
Get alerted when CVE-2022-3142 or the next vulnerability affects your stack