What’s Vulnerable › Vulnerabilities
CVE-2022-3151: WP Custom Cursors < 3.0.1 - Arbitrary Cursor Deletion via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-17 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP Custom Cursors WordPress plugin before 3.0.1 does not have CSRF check in place when deleting cursors, which could allow attackers to made a logged in admin delete arbitrary cursors via a CSRF attack.
Affected products
- WP Custom Cursors | WordPress Cursor Plugin: before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: WP Custom Cursors | WordPress Cursor Plugin 3.0.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/27816c70-58ad-4ffb-adcc-69eb1b210744
- https://wpscan.com/vulnerability/27816c70-58ad-4ffb-adcc-69eb1b210744
Get alerted when CVE-2022-3151 or the next vulnerability affects your stack