What’s Vulnerable › Vulnerabilities
CVE-2022-3154: Multiple Plugins from Viszt Peter - Multiple CSRF
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-10 · updated 2026-06-17
- Weakness: CWE-352
Description
The Woo Billingo Plus WordPress plugin before 4.4.5.4, Integration for Billingo & Gravity Forms WordPress plugin before 1.0.4, Integration for Szamlazz.hu & Gravity Forms WordPress plugin before 1.2.7 are lacking CSRF checks in various AJAX actions, which could allow attackers to make logged in Shop Managers and above perform unwanted actions, such as deactivate the plugin's license
Affected products
- Integration For Billingo & Gravity Forms Project Integration For Billingo & Gravity Forms: before 1.0.4 — fixed in 1.0.4
- Integration For Szamlazz.Hu & Gravity Forms Project Integration For Szamlazz.Hu & Gravity Forms: before 1.2.7 — fixed in 1.2.7
- Woo Billingo Plus Project Woo Billingo Plus: before 4.4.5.4 — fixed in 4.4.5.4
How to fix
Upgrade to a fixed version: Integration For Billingo & Gravity Forms Project Integration For Billingo & Gravity Forms 1.0.4; Integration For Szamlazz.Hu & Gravity Forms Project Integration For Szamlazz.Hu & Gravity Forms 1.2.7; Woo Billingo Plus Project Woo Billingo Plus 4.4.5.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/cda978b2-b31f-495d-8601-0aaa3e4b45cd
- https://wpscan.com/vulnerability/cda978b2-b31f-495d-8601-0aaa3e4b45cd
Get alerted when CVE-2022-3154 or the next vulnerability affects your stack