What’s Vulnerable › Vulnerabilities
CVE-2022-31604
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-01 · updated 2026-06-17
- Weakness: CWE-502
Description
NVFLARE, versions prior to 2.1.2, contains a vulnerability in its PKI implementation module, where The CA credentials are transported via pickle and no safe deserialization. The deserialization of Untrusted Data may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity.
Affected products
- NVIDIA Nvflare: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: NVIDIA Nvflare 2.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/NVIDIA/NVFlare/security/advisories/GHSA-rcxc-3w2m-mp8h
- https://github.com/NVIDIA/NVFlare/security/advisories/GHSA-rcxc-3w2m-mp8h
Get alerted when CVE-2022-31604 or the next vulnerability affects your stack