What’s Vulnerable › Vulnerabilities
CVE-2022-31605
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-01 · updated 2026-06-17
- Weakness: CWE-502
Description
NVFLARE, versions prior to 2.1.2, contains a vulnerability in its utils module, where YAML files are loaded via yaml.load() instead of yaml.safe_load(). The deserialization of Untrusted Data, may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity.
Affected products
- NVIDIA Nvflare: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: NVIDIA Nvflare 2.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/NVIDIA/NVFlare/security/advisories/GHSA-hrf3-622q-8366
- https://github.com/NVIDIA/NVFlare/security/advisories/GHSA-hrf3-622q-8366
Get alerted when CVE-2022-31605 or the next vulnerability affects your stack