What’s Vulnerable › Vulnerabilities
CVE-2022-31619
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-14 · updated 2026-06-17
- Weakness: CWE-798
Description
A vulnerability has been identified in Teamcenter V12.4 (All versions < V12.4.0.13), Teamcenter V13.0 (All versions < V13.0.0.9), Teamcenter V13.1 (All versions < V13.1.0.9), Teamcenter V13.2 (All versions < V13.2.0.9), Teamcenter V13.3 (All versions < V13.3.0.3), Teamcenter V14.0 (All versions < V14.0.0.2). Java EE Server Manager HTML Adaptor in Teamcenter consists of default hardcoded credentials. Access to the application allows a user to perform a series of actions that could potentially lead to remote code execution with elevated permissions.
Affected products
- Siemens Teamcenter: from 12.4 before 12.4.0.13; from 13.0 before 13.0.0.9; from 13.1 before 13.1.0.9; from 13.2 before 13.2.0.9; from 13.3 before 13.3.0.3; from 14.0 before 14.0.0.2 — fixed in 12.4.0.13, 13.0.0.9, 13.1.0.9, 13.2.0.9, 13.3.0.3, 14.0.0.2
How to fix
Upgrade to a fixed version: Siemens Teamcenter 12.4.0.13, 13.0.0.9, 13.1.0.9, 13.2.0.9. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-220589.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-220589.pdf
Get alerted when CVE-2022-31619 or the next vulnerability affects your stack