What’s Vulnerable › Vulnerabilities

CVE-2022-31621

Description

MariaDB Server before 10.7 is vulnerable to Denial of Service. In extra/mariabackup/ds_xbstream.cc, when an error occurs (stream_ctxt->dest_file == NULL) while executing the method xbstream_open, the held lock is not released correctly, which allows local users to trigger a denial of service due to the deadlock. Note: The vendor argues this is just an improper locking bug and not a vulnerability with adverse effects.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.2.41, 10.3.32, 10.4.22, 10.5.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-31621 or the next vulnerability affects your stack