What’s Vulnerable › Vulnerabilities

CVE-2022-31622

Description

MariaDB Server before 10.7 is vulnerable to Denial of Service. In extra/mariabackup/ds_compress.cc, when an error occurs (pthread_create returns a nonzero value) while executing the method create_worker_threads, the held lock is not released correctly, which allows local users to trigger a denial of service due to the deadlock. Note: The vendor argues this is just an improper locking bug and not a vulnerability with adverse effects.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.2.42, 10.3.33, 10.4.23, 10.5.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-31622 or the next vulnerability affects your stack