What’s Vulnerable › Vulnerabilities

CVE-2022-31624

Description

MariaDB Server before 10.7 is vulnerable to Denial of Service. While executing the plugin/server_audit/server_audit.c method log_statement_ex, the held lock lock_bigbuffer is not released correctly, which allows local users to trigger a denial of service due to the deadlock.

Affected products

How to fix

Upgrade to a fixed version: MariaDB 10.2.41, 10.3.32, 10.4.22, 10.5.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-31624 or the next vulnerability affects your stack