What’s Vulnerable › Vulnerabilities

CVE-2022-31625: Freeing unallocated memory in php_pgsql_free_params()

Description

In PHP versions 7.4.x below 7.4.30, 8.0.x below 8.0.20, and 8.1.x below 8.1.7, when using Postgres database extension, supplying invalid parameters to the parametrized query may lead to PHP attempting to free memory using uninitialized data as pointers. This could lead to RCE vulnerability or denial of service.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.4.30, 8.0.20, 8.1.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-31625 or the next vulnerability affects your stack