What’s Vulnerable › Vulnerabilities

CVE-2022-31628: phar wrapper can occur dos when using quine gzip file

Description

In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the phar uncompressor code would recursively uncompress "quines" gzip files, resulting in an infinite loop.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.4.31, 8.0.24, 8.1.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-31628 or the next vulnerability affects your stack