What’s Vulnerable › Vulnerabilities

CVE-2022-31629: $_COOKIE names string replacement (. -> _): cookie integrity vulnerabilities

Description

In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the vulnerability enables network and same-site attackers to set a standard insecure cookie in the victim's browser which is treated as a `__Host-` or `__Secure-` cookie by PHP applications.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.4.31, 8.0.24, 8.1.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-31629 or the next vulnerability affects your stack