What’s Vulnerable › Vulnerabilities
CVE-2022-31677
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-613
Description
An Insufficient Session Expiration issue was discovered in the Pinniped Supervisor (before v0.19.0). A user authenticating to Kubernetes clusters via the Pinniped Supervisor could potentially use their access token to continue their session beyond what proper use of their refresh token might allow.
Affected products
- Pinniped: from 0.3.0 before 0.19.0 — fixed in 0.19.0
- Pinniped Supervisor: Pinniped Supervisor (before v0.19.0)
How to fix
Upgrade to a fixed version: Pinniped 0.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/vmware-tanzu/pinniped/security/advisories/GHSA-rp4v-hhm6-rcv9
- https://github.com/vmware-tanzu/pinniped/security/advisories/GHSA-rp4v-hhm6-rcv9
Get alerted when CVE-2022-31677 or the next vulnerability affects your stack