What’s Vulnerable › Vulnerabilities
CVE-2022-31688
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-09 · updated 2026-06-17
- Weakness: CWE-79
Description
VMware Workspace ONE Assist prior to 22.10 contains a Reflected cross-site scripting (XSS) vulnerability. Due to improper user input sanitization, a malicious actor with some user interaction may be able to inject javascript code in the target user's window.
Affected products
- VMware Workspace ONE Assist: before 22.10 — fixed in 22.10
- VMware Workspace ONE Assist: VMware Workspace ONE Assist prior to 22.10
How to fix
Upgrade to a fixed version: VMware Workspace ONE Assist 22.10. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2022-0028.html
- https://www.vmware.com/security/advisories/VMSA-2022-0028.html
Get alerted when CVE-2022-31688 or the next vulnerability affects your stack