What’s Vulnerable › Vulnerabilities
CVE-2022-31690
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-31 · updated 2026-06-17
Description
Spring Security, versions 5.7 prior to 5.7.5, and 5.6 prior to 5.6.9, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can modify a request initiated by the Client (via the browser) to the Authorization Server which can lead to a privilege escalation on the subsequent approval. This scenario can happen if the Authorization Server responds with an OAuth2 Access Token Response containing an empty scope list (per RFC 6749, Section 5.1) on the subsequent request to the token endpoint to obtain the access token.
Affected products
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- Spring Security: from 5.6.0 before 5.6.9; from 5.7.0 before 5.7.5 — fixed in 5.6.9, 5.7.5
- Spring Security: from Spring Security (5.7 through 5.7.4 and 5.6 to 5.6.8 as well as older, unsupported versions)
How to fix
Upgrade to a fixed version: Spring Security 5.6.9, 5.7.5. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20221215-0010/
- https://tanzu.vmware.com/security/cve-2022-31690
- https://security.netapp.com/advisory/ntap-20221215-0010/
- https://tanzu.vmware.com/security/cve-2022-31690
Get alerted when CVE-2022-31690 or the next vulnerability affects your stack