What’s Vulnerable › Vulnerabilities
CVE-2022-31691
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-04 · updated 2026-06-17
- Weakness: CWE-94
Description
Spring Tools 4 for Eclipse version 4.16.0 and below as well as VSCode extensions such as Spring Boot Tools, Concourse CI Pipeline Editor, Bosh Editor and Cloudfoundry Manifest YML Support version 1.39.0 and below all use Snakeyaml library for YAML editing support. This library allows for some special syntax in the YAML that under certain circumstances allows for potentially harmful remote code execution by the attacker.
Affected products
- VMware Bosh Editor: from 1.0.0 before 1.40.0 — fixed in 1.40.0
- VMware Cloudfoundry Manifest Yml Support: from 1.0.0 before 1.40.0 — fixed in 1.40.0
- VMware Concourse Ci Pipeline Editor: from 1.0.0 before 1.40.0 — fixed in 1.40.0
- VMware Spring Boot Tools: from 1.0.0 before 1.40.0 — fixed in 1.40.0
- VMware Spring Tools: from 4.0.0 before 4.16.1 — fixed in 4.16.1
- Spring by VMware: Spring Tools 4 for Eclipse version 4.16.0 and below as well as VSCode extensions such as Spring Boot Tools, Concourse CI Pipeline Editor, Bosh Editor and Cloudfoundry Manifest YML Support version 1.39.0 and below all use Snakeyaml library for YAML editing support.
How to fix
Upgrade to a fixed version: VMware Bosh Editor 1.40.0; VMware Cloudfoundry Manifest Yml Support 1.40.0; VMware Concourse Ci Pipeline Editor 1.40.0; VMware Spring Boot Tools 1.40.0; VMware Spring Tools 4.16.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-31691 or the next vulnerability affects your stack