What’s Vulnerable › Vulnerabilities
CVE-2022-31694
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-18 · updated 2026-06-17
- Weakness: CWE-427
Description
InstallBuilder Qt installers built with versions previous to 22.10 try to load DLLs from the installer binary parent directory when displaying popups. This may allow an attacker to plant a malicious DLL in the installer parent directory to allow executing code with the privileges of the installer (when the popup triggers the loading of the library). Exploiting these type of vulnerabilities generally require that an attacker has access to a vulnerable machine to plant the malicious DLL.
Affected products
- VMware InstallBuilder: before 22.10.0 — fixed in 22.10.0
How to fix
Upgrade to a fixed version: VMware InstallBuilder 22.10.0. Check the vendor advisory for mitigations.
References
- https://blog.installbuilder.com/2022/11/installbuilder-22100-released.html
- https://blog.installbuilder.com/2022/11/installbuilder-22100-released.html
Get alerted when CVE-2022-31694 or the next vulnerability affects your stack