What’s Vulnerable › Vulnerabilities
CVE-2022-31696
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-13 · updated 2026-06-17
- Weakness: CWE-787
Description
VMware ESXi contains a memory corruption vulnerability that exists in the way it handles a network socket. A malicious actor with local access to ESXi may exploit this issue to corrupt memory leading to an escape of the ESXi sandbox.
Affected products
- VMware Cloud Foundation: from 3.0 before 3.10; from 4.0 before 4.3.11; 3.10, 3.11; 4.3.11, 4.4, 4.4.1, 4.4.1.1, 4.5 (and their updates) — fixed in 3.10, 4.3.11
- VMware ESXi: 6.5-650-201701001, 6.5-650-201703001, 6.5-650-201703002, 6.5-650-201704001, 6.5-650-201707101, 6.5-650-201707102 (+247); 6.5, 6.7, 7.0
- VMware ESXi, VMware Cloud Foundation: from VMware ESXi (7.0 prior through ESXi70U3si-20841705, 6.7 prior to ESXi670-202210101-SG, 6.5 prior to ESXi650-202210101-SG), VMware Cloud Foundation (4.x, 3.x)
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 3.10, 4.3.11. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2022-0030.html
- https://www.vmware.com/security/advisories/VMSA-2022-0030.html
Get alerted when CVE-2022-31696 or the next vulnerability affects your stack