What’s Vulnerable › Vulnerabilities
CVE-2022-31705
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-14 · updated 2026-06-17
- Weakness: CWE-787
Description
VMware ESXi, Workstation, and Fusion contain a heap out-of-bounds write vulnerability in the USB 2.0 controller (EHCI). A malicious actor with local administrative privileges on a virtual machine may exploit this issue to execute code as the virtual machine's VMX process running on the host. On ESXi, the exploitation is contained within the VMX sandbox whereas, on Workstation and Fusion, this may lead to code execution on the machine where Workstation or Fusion is installed.
Affected products
- VMware ESXi: 7.0-beta, 7.0-update_1, 7.0-update_1a, 7.0-update_1b, 7.0-update_1c, 7.0-update_1d (+11); 7.0, 8.0
- VMware Fusion: from 12.0.0 before 12.2.5 — fixed in 12.2.5
- VMware Workstation: from 16.0.0 before 16.2.5 — fixed in 16.2.5
- VMware ESXi, VMware Workstation Pro / Player, VMware Fusion Pro / Fusion (Fusion), VMware Cloud Foundation: from VMware ESXi (8.0 prior through ESXi80a-20842819, 7.0 prior to ESXi70U3si-20841705, VMware Workstation Pro / Player (16.x prior to 16.2.5), VMware Fusion Pro / Fusion (12.x prior to 12.2.5), VMware Cloud Foundation (4.x, 3.x)
How to fix
Upgrade to a fixed version: VMware Fusion 12.2.5; VMware Workstation 16.2.5. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2022-0033.html
- https://www.vmware.com/security/advisories/VMSA-2022-0033.html
Get alerted when CVE-2022-31705 or the next vulnerability affects your stack