What’s Vulnerable › Vulnerabilities

CVE-2022-3171: Memory handling vulnerability in ProtocolBuffers Java core and lite

Description

A parsing issue with binary data in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.

Affected products

How to fix

Upgrade to a fixed version: Google-Protobuf 3.16.3, 3.19.6, 3.20.3, 3.21.7; Google protobuf-java 3.16.3, 3.19.6, 3.20.3, 3.21.7; Google protobuf-javalite 3.16.3, 3.19.6, 3.20.3, 3.21.7; Google protobuf-kotlin 3.16.3, 3.19.6, 3.20.3, 3.21.7; Google Protobuf-Kotlin-Lite 3.16.3, 3.19.6, 3.20.3, 3.21.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3171 or the next vulnerability affects your stack