What’s Vulnerable › Vulnerabilities
CVE-2022-31734
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cisco Catalyst 2940 Series Switches provided by Cisco Systems, Inc. contain a reflected cross-site scripting vulnerability regarding error page generation. An arbitrary script may be executed on the web browser of the user who is using the product. The affected firmware is prior to 12.2(50)SY released in 2011, and Cisco Catalyst 2940 Series Switches have been retired since January 2015
Affected products
- Cisco Ws-C2940-8Tf-S Firmware: before 12.2\(50\)sy — fixed in 12.2\(50\)sy
- Cisco Ws-C2940-8Tt-S Firmware: before 12.2\(50\)sy — fixed in 12.2\(50\)sy
How to fix
Upgrade to a fixed version: Cisco Ws-C2940-8Tf-S Firmware 12.2\(50\)sy; Cisco Ws-C2940-8Tt-S Firmware 12.2\(50\)sy. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/jp/JVN94363766/index.html
- https://www.cisco.com/c/en/us/obsolete/switches/cisco-catalyst-2940-series-switches.html
- https://jvn.jp/en/jp/JVN94363766/index.html
- https://www.cisco.com/c/en/us/obsolete/switches/cisco-catalyst-2940-series-switches.html
Get alerted when CVE-2022-31734 or the next vulnerability affects your stack