What’s Vulnerable › Vulnerabilities
CVE-2022-31740
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-119
Description
On arm64, WASM code could have resulted in incorrect assembly generation leading to a register allocation problem, and a potentially exploitable crash. This vulnerability affects Thunderbird < 91.10, Firefox < 101, and Firefox ESR < 91.10.
Affected products
- Mozilla Firefox: before 101.0 — fixed in 101.0
- Mozilla Firefox ESR: before 91.10 — fixed in 91.10
- Mozilla Thunderbird: before 91.10 — fixed in 91.10
How to fix
Upgrade to a fixed version: Mozilla Firefox 101.0; Mozilla Firefox ESR 91.10; Mozilla Thunderbird 91.10. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1766806
- https://www.mozilla.org/security/advisories/mfsa2022-20/
- https://www.mozilla.org/security/advisories/mfsa2022-21/
- https://www.mozilla.org/security/advisories/mfsa2022-22/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1766806
- https://www.mozilla.org/security/advisories/mfsa2022-20/
- https://www.mozilla.org/security/advisories/mfsa2022-21/
- https://www.mozilla.org/security/advisories/mfsa2022-22/
Get alerted when CVE-2022-31740 or the next vulnerability affects your stack