What’s Vulnerable › Vulnerabilities
CVE-2022-31767
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-24 · updated 2026-06-17
- Weakness: CWE-78
Description
IBM CICS TX Standard and Advanced 11.1 could allow a remote attacker to execute arbitrary commands on the system by sending a specially crafted request. IBM X-Force ID: 227980.
Affected products
- IBM CICS TX Advanced: before 11.1; 11.1 — fixed in 11.1
How to fix
Upgrade to a fixed version: IBM CICS TX Advanced 11.1. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/227980
- https://www.ibm.com/support/pages/node/6597531
- https://www.ibm.com/support/pages/node/6597533
- https://exchange.xforce.ibmcloud.com/vulnerabilities/227980
- https://www.ibm.com/support/pages/node/6597531
- https://www.ibm.com/support/pages/node/6597533
Get alerted when CVE-2022-31767 or the next vulnerability affects your stack