What’s Vulnerable › Vulnerabilities

CVE-2022-31774

Description

IBM DataPower Gateway 10.0.2.0 through 10.0.4.0, 10.0.1.0 through 10.0.1.8, 10.5.0.0, and 2018.4.1.0 through 2018.4.1.21 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 228358.

Affected products

How to fix

Upgrade to a fixed version: IBM DataPower Gateway 11.0.0 10.5.0.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-31774 or the next vulnerability affects your stack