What’s Vulnerable › Vulnerabilities
CVE-2022-31776
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-918
Description
IBM DataPower Gateway 10.0.2.0 through 10.0.4.0, 10.0.1.0 through 10.0.1.8, 10.5.0.0, and 2018.4.1.0 through 2018.4.1.21 is vulnerable to server-side request forgery (SSRF). This may allow an authenticated attacker to send unauthorized requests from the system, potentially leading to network enumeration or facilitating other attacks. IBM X-Force ID: 228433.
Affected products
- IBM DataPower Gateway 11.0.0: from 10.0.1.0 through 10.0.1.8; from 10.0.2.0 before 10.5.0.1; from 2018.4.1.0 through 2018.4.1.21; 10.5.0.0 — fixed in 10.5.0.1
How to fix
Upgrade to a fixed version: IBM DataPower Gateway 11.0.0 10.5.0.1. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/228433
- https://www.ibm.com/support/pages/node/6608604
- https://exchange.xforce.ibmcloud.com/vulnerabilities/228433
- https://www.ibm.com/support/pages/node/6608604
Get alerted when CVE-2022-31776 or the next vulnerability affects your stack