What’s Vulnerable › Vulnerabilities
CVE-2022-31777: Apache Spark XSS vulnerability in log viewer UI Javascript
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-01 · updated 2026-06-17
- Weakness: CWE-74
Description
A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.
Affected products
- Apache Software Foundation Apache Spark: before 3.2.2; 3.3.0 — fixed in 3.2.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Spark 3.2.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/11/01/14
- https://lists.apache.org/thread/60mgbswq2lsmrxykfxpqq13ztkm2ht6q
- http://www.openwall.com/lists/oss-security/2022/11/01/14
- https://lists.apache.org/thread/60mgbswq2lsmrxykfxpqq13ztkm2ht6q
Get alerted when CVE-2022-31777 or the next vulnerability affects your stack