What’s Vulnerable › Vulnerabilities
CVE-2022-3178: Buffer Over-read in gpac/gpac
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-12 · updated 2026-06-17
- Weakness: CWE-126
Description
Buffer Over-read in GitHub repository gpac/gpac prior to 2.1.0-DEV.
Affected products
- GPAC: before 2.1.0-dev — fixed in 2.1.0-dev
How to fix
Upgrade to a fixed version: GPAC 2.1.0-dev. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/77510778516803b7f7402d7423c6d6bef50254c3
- https://huntr.dev/bounties/f022fc50-3dfd-450a-ab47-3d75d2bf44c0
- https://github.com/gpac/gpac/commit/77510778516803b7f7402d7423c6d6bef50254c3
- https://huntr.dev/bounties/f022fc50-3dfd-450a-ab47-3d75d2bf44c0
Get alerted when CVE-2022-3178 or the next vulnerability affects your stack