What’s Vulnerable › Vulnerabilities
CVE-2022-3179: Weak Password Requirements in ikus060/rdiffweb
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-13 · updated 2026-06-17
- Weakness: CWE-521
Description
Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.4.2.
Affected products
- ikus060/rdiffweb: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: ikus060/rdiffweb 2.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/ikus060/rdiffweb/commit/233befc33bdc45d4838c773d5aed4408720504c5
- https://huntr.dev/bounties/58eae29e-3619-449d-9bba-fdcbabcba5fe
- https://github.com/ikus060/rdiffweb/commit/233befc33bdc45d4838c773d5aed4408720504c5
- https://huntr.dev/bounties/58eae29e-3619-449d-9bba-fdcbabcba5fe
Get alerted when CVE-2022-3179 or the next vulnerability affects your stack