What’s Vulnerable › Vulnerabilities
CVE-2022-31802: Partial string comparison in CODESYS gateway server
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-24 · updated 2026-06-17
- Weakness: CWE-187
Description
In CODESYS Gateway Server V2 for versions prior to V2.3.9.38 only a part of the the specified password is been compared to the real CODESYS Gateway password. An attacker may perform authentication by specifying a small password that matches the corresponding part of the longer real CODESYS Gateway password.
Affected products
- CODESYS Gateway Server V2: from 2.0 before 2.3.9.38 — fixed in 2.3.9.38
How to fix
Upgrade to a fixed version: CODESYS Gateway Server V2 2.3.9.38. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17141&token=17867e35cfd30c77ba0137f9a17b3a557a4b7b66&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17141&token=17867e35cfd30c77ba0137f9a17b3a557a4b7b66&download=
Get alerted when CVE-2022-31802 or the next vulnerability affects your stack