What’s Vulnerable › Vulnerabilities
CVE-2022-31804: CODESYS Gateway server prone to denial of service attack due to excessive memory allocation
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-24 · updated 2026-06-17
- Weakness: CWE-789
Description
The CODESYS Gateway Server V2 does not verifiy that the size of a request is within expected limits. An unauthenticated attacker may allocate an arbitrary amount of memory, which may lead to a crash of the Gateway due to an out-of-memory condition.
Affected products
- CODESYS Gateway Server V2: from 2.0 before 2.3.9.38 — fixed in 2.3.9.38
How to fix
Upgrade to a fixed version: CODESYS Gateway Server V2 2.3.9.38. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17141&token=17867e35cfd30c77ba0137f9a17b3a557a4b7b66&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17141&token=17867e35cfd30c77ba0137f9a17b3a557a4b7b66&download=
Get alerted when CVE-2022-31804 or the next vulnerability affects your stack