What’s Vulnerable › Vulnerabilities
CVE-2022-31806: Insecure default settings in CODESYS Runtime Toolkit 32 bit full and CODESYS PLCWinNT
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-24 · updated 2026-06-17
- Weakness: CWE-1188
Description
In CODESYS V2 PLCWinNT and Runtime Toolkit 32 in versions prior to V2.4.7.57 password protection is not enabled by default and there is no information or prompt to enable password protection at login in case no password is set at the controller.
Affected products
- CODESYS PLCWinNT: before 2.4.7.57 — fixed in 2.4.7.57
- CODESYS Runtime Toolkit: before 2.4.7.57 — fixed in 2.4.7.57
How to fix
Upgrade to a fixed version: CODESYS PLCWinNT 2.4.7.57; CODESYS Runtime Toolkit 2.4.7.57. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17140&token=6aa2c5c4a8b83b8b09936fefed5b0b11f9d2cc6c&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17140&token=6aa2c5c4a8b83b8b09936fefed5b0b11f9d2cc6c&download=
Get alerted when CVE-2022-31806 or the next vulnerability affects your stack