What’s Vulnerable › Vulnerabilities
CVE-2022-31808
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-14 · updated 2026-10-24
- Weakness: CWE-20
Description
A vulnerability has been identified in SiPass integrated AC5102 (ACC-G2) (All versions < V2.85.44), SiPass integrated ACC-AP (All versions < V2.85.43). Affected devices improperly sanitize user input on the telnet command line interface. This could allow an authenticated user to escalate privileges by injecting arbitrary commands that are executed with root privileges.
Affected products
- Siemens Sipass Integrated Ac5102 (Acc-G2) Firmware: before 2.85.44 — fixed in 2.85.44
- Siemens Sipass Integrated Acc-Ap Firmware: before 2.85.43 — fixed in 2.85.43
How to fix
Upgrade to a fixed version: Siemens Sipass Integrated Ac5102 (Acc-G2) Firmware 2.85.44; Siemens Sipass Integrated Acc-Ap Firmware 2.85.43. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-658793.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-658793.pdf
Get alerted when CVE-2022-31808 or the next vulnerability affects your stack