What’s Vulnerable › Vulnerabilities
CVE-2022-31810
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-11 · updated 2026-10-23
- Weakness: CWE-20
Description
A vulnerability has been identified in SiPass integrated (All versions < V2.90.3.8). Affected server applications improperly check the size of data packets received for the configuration client login, causing a stack-based buffer overflow. This could allow an unauthenticated remote attacker to crash the server application, creating a denial of service condition.
Affected products
- Siemens SiPass integrated: before 2.90.3.8 — fixed in 2.90.3.8
How to fix
Upgrade to a fixed version: Siemens SiPass integrated 2.90.3.8. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-924149.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-924149.pdf
Get alerted when CVE-2022-31810 or the next vulnerability affects your stack