What’s Vulnerable › Vulnerabilities
CVE-2022-32086
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-01 · updated 2026-06-17
Description
MariaDB v10.4 to v10.8 was discovered to contain a segmentation fault via the component Item_field::fix_outer_field.
Affected products
- MariaDB: from 10.4.0 before 10.4.25; from 10.5.0 before 10.5.16; from 10.6.0 before 10.6.8; from 10.7.0 before 10.7.4 — fixed in 10.4.25, 10.5.16, 10.6.8, 10.7.4
How to fix
Upgrade to a fixed version: MariaDB 10.4.25, 10.5.16, 10.6.8, 10.7.4. Check the vendor advisory for mitigations.
References
- https://jira.mariadb.org/browse/MDEV-26412
- https://security.netapp.com/advisory/ntap-20220826-0007/
- https://jira.mariadb.org/browse/MDEV-26412
- https://security.netapp.com/advisory/ntap-20220826-0007/
Get alerted when CVE-2022-32086 or the next vulnerability affects your stack