What’s Vulnerable › Vulnerabilities
CVE-2022-32091
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-01 · updated 2026-06-17
- Weakness: CWE-416
Description
MariaDB v10.7 was discovered to contain an use-after-poison in in __interceptor_memset at /libsanitizer/sanitizer_common/sanitizer_common_interceptors.inc.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 35, 36, 37
- MariaDB: from 10.3.0 before 10.3.36; from 10.4.0 before 10.4.26; from 10.5.0 before 10.5.17; from 10.6.0 before 10.6.9; from 10.7.0 before 10.7.5; from 10.8.0 before 10.8.4 — fixed in 10.3.36, 10.4.26, 10.5.17, 10.6.9, 10.7.5, 10.8.4
How to fix
Upgrade to a fixed version: MariaDB 10.3.36, 10.4.26, 10.5.17, 10.6.9. Check the vendor advisory for mitigations.
References
- https://jira.mariadb.org/browse/MDEV-26431
- https://lists.debian.org/debian-lts-announce/2022/09/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WCOEGSVMIEXDZHBOSV6WVF7FAVRBR2JE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WTVAONAZXJFGHAJ4RP2OF3EAMQCOTDSQ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZHISY4YVO4S5QJYYIXCIAXBM7INOL4VY/
- https://security.netapp.com/advisory/ntap-20220818-0005/
- https://jira.mariadb.org/browse/MDEV-26431
- https://lists.debian.org/debian-lts-announce/2022/09/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WCOEGSVMIEXDZHBOSV6WVF7FAVRBR2JE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WTVAONAZXJFGHAJ4RP2OF3EAMQCOTDSQ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZHISY4YVO4S5QJYYIXCIAXBM7INOL4VY/
- https://security.netapp.com/advisory/ntap-20220818-0005/
Get alerted when CVE-2022-32091 or the next vulnerability affects your stack