What’s Vulnerable › Vulnerabilities
CVE-2022-32096
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-13 · updated 2026-06-17
- Weakness: CWE-120
Description
Rhonabwy before v1.1.5 was discovered to contain a buffer overflow via the component r_jwe_aesgcm_key_unwrap. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted JWE token.
Affected products
- Rhonabwy Project Rhonabwy: before 1.1.5 — fixed in 1.1.5
How to fix
Upgrade to a fixed version: Rhonabwy Project Rhonabwy 1.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/babelouest/rhonabwy/
- https://github.com/babelouest/rhonabwy/commit/b4c2923a1ba4fabf9b55a89244127e153a3e549b
- https://github.com/babelouest/rhonabwy/
- https://github.com/babelouest/rhonabwy/commit/b4c2923a1ba4fabf9b55a89244127e153a3e549b
Get alerted when CVE-2022-32096 or the next vulnerability affects your stack