What’s Vulnerable › Vulnerabilities
CVE-2022-32138: CODESYS runtime system prone to denial of service due to Unexpected Sign Extension
- Severity: medium (CVSS 6.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-24 · updated 2026-06-17
- Weakness: CWE-194
Description
In multiple CODESYS products, a remote attacker may craft a request which may cause an unexpected sign extension, resulting in a denial-of-service condition or memory overwrite.
Affected products
- CODESYS PLCWinNT: from 2.0 before 2.4.7.57 — fixed in 2.4.7.57
- CODESYS Runtime Toolkit: from 2.0 before 2.4.7.57 — fixed in 2.4.7.57
How to fix
Upgrade to a fixed version: CODESYS PLCWinNT 2.4.7.57; CODESYS Runtime Toolkit 2.4.7.57. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17139&token=ec67d15a433b61c77154166c20c78036540cacb0&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17139&token=ec67d15a433b61c77154166c20c78036540cacb0&download=
Get alerted when CVE-2022-32138 or the next vulnerability affects your stack