What’s Vulnerable › Vulnerabilities
CVE-2022-32140: CODESYS runtime system prone to denial of service due to buffer copy
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-24 · updated 2026-06-17
- Weakness: CWE-120
Description
Multiple CODESYS products are affected to a buffer overflow.A low privileged remote attacker may craft a request, which can cause a buffer copy without checking the size of the service, resulting in a denial-of-service condition. User Interaction is not required.
Affected products
- CODESYS PLCWinNT: from 2.0 before 2.4.7.57 — fixed in 2.4.7.57
- CODESYS Runtime Toolkit: from 2.0 before 2.4.7.57 — fixed in 2.4.7.57
How to fix
Upgrade to a fixed version: CODESYS PLCWinNT 2.4.7.57; CODESYS Runtime Toolkit 2.4.7.57. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17139&token=ec67d15a433b61c77154166c20c78036540cacb0&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17139&token=ec67d15a433b61c77154166c20c78036540cacb0&download=
Get alerted when CVE-2022-32140 or the next vulnerability affects your stack