What’s Vulnerable › Vulnerabilities
CVE-2022-32156: Splunk Enterprise and Universal Forwarder CLI connections lacked TLS cert validation
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-15 · updated 2026-06-17
- Weakness: CWE-295
Description
In Splunk Enterprise and Universal Forwarder versions before 9.0, the Splunk command-line interface (CLI) did not validate TLS certificates while connecting to a remote Splunk platform instance by default. After updating to version 9.0, see Configure TLS host name validation for the Splunk CLI https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/EnableTLSCertHostnameValidation#Configure_TLS_host_name_validation_for_the_Splunk_CLI to enable the remediation. The vulnerability does not affect the Splunk Cloud Platform. At the time of publishing, we have no evidence of exploitation of this vulnerability by external parties. The issue requires conditions beyond the control of a potential bad actor such as a machine-in-the-middle attack. Hence, Splunk rates the complexity of the attack as High.
Affected products
- Splunk Enterprise: before 9.0 — fixed in 9.0
- Splunk Universal Forwarder: before 9.0 — fixed in 9.0
How to fix
Upgrade to a fixed version: Splunk Enterprise 9.0; Splunk Universal Forwarder 9.0. Check the vendor advisory for mitigations.
References
- https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/EnableTLSCertHostnameValidation#Configure_TLS_host_name_validation_for_the_Splunk_CLI
- https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/Updates
- https://www.splunk.com/en_us/product-security/announcements/svd-2022-0606.html
- https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/EnableTLSCertHostnameValidation#Configure_TLS_host_name_validation_for_the_Splunk_CLI
- https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/Updates
- https://www.splunk.com/en_us/product-security/announcements/svd-2022-0606.html
Get alerted when CVE-2022-32156 or the next vulnerability affects your stack