What’s Vulnerable › Vulnerabilities
CVE-2022-32157: Splunk Enterprise deployment servers allow unauthenticated forwarder bundle downloads
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-15 · updated 2026-06-17
- Weakness: CWE-306
Description
Splunk Enterprise deployment servers in versions before 9.0 allow unauthenticated downloading of forwarder bundles. Remediation requires you to update the deployment server to version 9.0 and Configure authentication for deployment servers and clients (https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/ConfigDSDCAuthEnhancements#Configure_authentication_for_deployment_servers_and_clients). Once enabled, deployment servers can manage only Universal Forwarder versions 9.0 and higher. Though the vulnerability does not directly affect Universal Forwarders, remediation requires updating all Universal Forwarders that the deployment server manages to version 9.0 or higher prior to enabling the remediation.
Affected products
- Splunk Enterprise: before 9.0 — fixed in 9.0
How to fix
Upgrade to a fixed version: Splunk Enterprise 9.0. Check the vendor advisory for mitigations.
References
- https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/ConfigDSDCAuthEnhancements#Configure_authentication_for_deployment_servers_and_clients
- https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/Updates
- https://research.splunk.com/application/splunk_process_injection_forwarder_bundle_downloads/
- https://www.splunk.com/en_us/product-security/announcements/svd-2022-0607.html
- https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/ConfigDSDCAuthEnhancements#Configure_authentication_for_deployment_servers_and_clients
- https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/Updates
- https://research.splunk.com/application/splunk_process_injection_forwarder_bundle_downloads/
- https://www.splunk.com/en_us/product-security/announcements/svd-2022-0607.html
Get alerted when CVE-2022-32157 or the next vulnerability affects your stack