What’s Vulnerable › Vulnerabilities
CVE-2022-32158: Splunk Enterprise deployment servers allow client publishing of forwarder bundles
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-06-15 · updated 2026-06-17
- Weakness: CWE-284
Description
Splunk Enterprise deployment servers in versions before 8.1.10.1, 8.2.6.1, and 9.0 let clients deploy forwarder bundles to other deployment clients through the deployment server. An attacker that compromised a Universal Forwarder endpoint could use the vulnerability to execute arbitrary code on all other Universal Forwarder endpoints subscribed to the deployment server.
Affected products
- Splunk Enterprise: before 9.0 — fixed in 9.0
How to fix
Upgrade to a fixed version: Splunk Enterprise 9.0. Check the vendor advisory for mitigations.
References
- https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/Updates
- https://www.splunk.com/en_us/product-security/announcements/svd-2022-0608.html
- https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/Updates
- https://www.splunk.com/en_us/product-security/announcements/svd-2022-0608.html
Get alerted when CVE-2022-32158 or the next vulnerability affects your stack