What’s Vulnerable › Vulnerabilities
CVE-2022-3220: Advanced Comment Form < 1.2.1 - Admin+ Authenticated Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Advanced Comment Form WordPress plugin before 1.2.1 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Advanced Comment Form: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: Advanced Comment Form 1.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/cb6f4953-e68b-48f3-a821-a1d77e5476ef
- https://wpscan.com/vulnerability/cb6f4953-e68b-48f3-a821-a1d77e5476ef
Get alerted when CVE-2022-3220 or the next vulnerability affects your stack