What’s Vulnerable › Vulnerabilities
CVE-2022-32209: Rails::Html::Sanitizer vulnerable to Cross-site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 30.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-24 · updated 2026-06-17
- Weakness: CWE-79
Description
# Possible XSS Vulnerability in Rails::Html::SanitizerThere is a possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer.This vulnerability has been assigned the CVE identifier CVE-2022-32209.Versions Affected: ALLNot affected: NONEFixed Versions: v1.4.3## ImpactA possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer may allow an attacker to inject content if the application developer has overridden the sanitizer's allowed tags to allow both `select` and `style` elements.Code is only impacted if allowed tags are being overridden. This may be done via application configuration:```ruby# In config/application.rbconfig.action_view.sanitized_allowed_tags = ["select", "style"]```see https://guides.rubyonrails.org/configuring.html#configuring-action-viewOr it may be done with a `:tags` option to the Action View helper `sanitize`:```<%= sanitize @comment.body, tags: ["select", "style"] %>```see https://api.rubyonrails.org/classes/ActionView/Helpers/SanitizeHelper.html#method-i-sanitizeOr it may be done with Rails::Html::SafeListSanitizer directly:```ruby# class-level optionRails::Html::SafeListSanitizer.allowed_tags = ["select", "style"]```or```ruby# instance-level optionRails::Html::SafeListSanitizer.new.sanitize(@article.body, tags: ["select", "style"])```All users overriding the allowed tags by any of the above mechanisms to include both "select" and "style" should either upgrade or use one of the workarounds immediately.## ReleasesThe FIXED releases are available at the normal locations.## WorkaroundsRemove either `select` or `style` from the overridden allowed tags.## CreditsThis vulnerability was responsibly reported by [windshock](https://hackerone.com/windshock?type=user).
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 35, 36
- rails-html-sanitizer: before 1.4.3 — fixed in 1.4.3
- Rubygems Rails-Html-Sanitizer: before 1.4.3; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.1.0 (+5) — fixed in 1.4.3
How to fix
Upgrade to a fixed version: rails-html-sanitizer 1.4.3; Rubygems Rails-Html-Sanitizer 1.4.3. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/1530898
- https://lists.debian.org/debian-lts-announce/2022/12/msg00012.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AGRLWBEB3S5AU3D4TTROIS7O6QPHDTRH/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NHDACMCLWE32BZZTSNWQPIFUAD5I6Q47/
- https://hackerone.com/reports/1530898
- https://lists.debian.org/debian-lts-announce/2022/12/msg00012.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00045.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AGRLWBEB3S5AU3D4TTROIS7O6QPHDTRH/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NHDACMCLWE32BZZTSNWQPIFUAD5I6Q47/
Get alerted when CVE-2022-32209 or the next vulnerability affects your stack