What’s Vulnerable › Vulnerabilities
CVE-2022-32212
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-14 · updated 2026-06-17
- Weakness: CWE-284
Description
A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.20.0, <18.5.0 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly check if an IP address is invalid before making DBS requests allowing rebinding attacks.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 35, 36, 37
- Node.js: from 14.0.0 through 14.14.0; from 14.15.0 before 14.20.1; from 16.0.0 through 16.12.0; from 16.13.0 before 16.17.1; from 18.0.0 before 18.5.0 — fixed in 14.20.1, 16.17.1, 18.5.0
- Siemens SINEC INS: before 1.0; 1.0, 1.0-sp1 — fixed in 1.0
How to fix
Upgrade to a fixed version: Node.js 14.20.1, 16.17.1, 18.5.0; Siemens SINEC INS 1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-32212 or the next vulnerability affects your stack