What’s Vulnerable › Vulnerabilities

CVE-2022-32213

Description

The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not correctly parse and validate Transfer-Encoding headers and can lead to HTTP Request Smuggling (HRS).

Affected products

How to fix

Upgrade to a fixed version: Llhttp 2.1.5, 6.0.7; Node.js 14.20.1, 16.17.1, 18.9.1; Stormshield Management Center 3.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-32213 or the next vulnerability affects your stack