What’s Vulnerable › Vulnerabilities

CVE-2022-32214

Description

The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not strictly use the CRLF sequence to delimit HTTP requests. This can lead to HTTP Request Smuggling (HRS).

Affected products

How to fix

Upgrade to a fixed version: Llhttp 2.1.5, 6.0.7; Node.js 14.20.0, 16.16.0, 18.5.0; Stormshield Management Center 3.3.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-32214 or the next vulnerability affects your stack