What’s Vulnerable › Vulnerabilities
CVE-2022-32218
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-23 · updated 2026-06-17
- Weakness: CWE-200
Description
An information disclosure vulnerability exists in Rocket.Chat <v5, <v4.8.2 and <v4.7.5 due to the actionLinkHandler method was found to allow Message ID Enumeration with Regex MongoDB queries.
Affected products
- Rocket.Chat: before 4.7.5; from 4.8.0 before 4.8.2 — fixed in 4.7.5, 4.8.2
How to fix
Upgrade to a fixed version: Rocket.Chat 4.7.5, 4.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-32218 or the next vulnerability affects your stack